Storm 1.2.1 Released

Posted on Feb 19, 2018 by P. Taylor Goetz

The Apache Storm community is pleased to announce that version 1.2.1 has been released and is available from the downloads page.

This is a maintenance release that includes a number of important bug fixes that improve Storm's performance, stability and fault tolerance. We encourage users of previous versions to upgrade to this latest release.

In the 1.2.0 release, an LGPL-licensed binary dependency was inadvertently included. The 1.2.0 has since been removed from distribution.

The dependency in question (Remote Tea Runtime) is required when using the Ganglia reporter for the new metrics system. To enable the Ganglia reporter you will need to download the following jar and place it in the lib directory of the Storm installation.

Thanks

Special thanks are due to all those who have contributed to Apache Storm -- whether through direct code contributions, documentation, bug reports, or helping other users on the mailing lists. Your efforts are much appreciated.

Changes in this Release

Bug

  • [STORM-2951] - Storm binaries packages oncrpc jar which is LGPL

Test

  • [STORM-2841] - testNoAcksIfFlushFails UT fails with NullPointerException